• This topic has 7 replies, 2 voices, and was last updated 2 years ago by vako.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #60452
    Spike
    Participant
    Premium Member

    Hi Vako, sorry to bother you again my friend.

    Wonder if you could help me stop Dark Mode adding what looks to me like a transparency?

    I’ve a photography website & although the trans is small, it does add a significant contrast pop to my photographs. I’m sure it will frustrate some of my visitors.

    I thought I found it… something like .ashe-dark-mode but I lost it again.. you know how it is 😉

    Kindest regards, Steve

    #60455
    vako
    Keymaster
    WP Royal Team

    Hi Steve,

     

    Can you please describe the issue you have in more detailed? Please share a direct link to the page where the issue appears and for more clarifications, screenshots will be much appreciated.

     

    Kind Regards

    #60457
    Spike
    Participant
    Premium Member

    Hey Vako, sure thing..

    Homepage has an image at the bottom of page, a before/after photograph.

    A good demo is to expose the black & white image, then from the top menu bar, toggle dark mode on / off.

    You’ll see when dark mode is enabled the BnW photo gets very dark, and contrasty. In day mode that darkness is removed.

    Obviously I don’t want the visual mode to affect the quality of my images.

    The change in screen doesn’t apply to everything site-wide.

    I think the attribute may be .ashe-dark-mode but I’m unsure. I recall seeing..

    body .ashe-dark-mode – and an opacity setting that affected the transparency, but can’t find it now?

    https://stevepike.photography

    NaturalAdjusted

    So it is the extra darkness being applied to the images, when in dark mode, that I really need to stop happening if possible?

    Hope you can help with this one my friend.

    Regards, Steve

    #60458
    Spike
    Participant
    Premium Member

    Update Vako,

    Have found by inspecting the page, the following;

    body.ashe-dark-mode img
                    filter brightness(.8) contrast(1.2)

    If I disable this the additional contrast is removed & my images look correct.

    Hope this helps? Oh.. and I’ve tried applying adjustments in my child/style.css but to no good affect :/

    Thanks

    #60474
    vako
    Keymaster
    WP Royal Team

    Hi Steve,

     

    At first, sorry for the late reply, we had holidays.

    I will redirect this topic to the developer’s board and they will contact you.

     

    Kind Regards

    #60480
    Spike
    Participant
    Premium Member

    Many thanks Vako, I await a reply from someone.

    Steve

    #60481
    Spike
    Participant
    Premium Member

    UPDATE

    Hey Vako, just wanted to complete the post, in-case it helps anyone else.

    I’ve found;

    body.ashe-dark-mode img {
    filter: none !important;
    }

    Resolves the filter & images appear correct in both Light and Dark modes.

    Thanks go to Photomentor support who I asked if there was am issue with the Before/After slider they provide me in their Plugin.

    Hope it saves some work for your guys too 👍

    #60509
    vako
    Keymaster
    WP Royal Team

    Hi Steve,

     

    We are glad that you were able to found out the solution by yourself.

    Feel free to contact us at any time, we are more than happy to help.

     

    Kind Regards

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.